[RESOLVED] P3D V4.3 stuck at splash screen

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
Posts: 1
Joined: Fri Jul 13, 2018 12:45 pm

[RESOLVED] P3D V4.3 stuck at splash screen

Postby lowigiej » Fri Jul 13, 2018 1:23 pm

i give up 😓😓😓 P3D keeps blocking at the loading screen. I didnt touch the sim for 7 days due to holiday and before that it worked fine. however when i came back and started P3D it kept hanging and stopped working altough i didn't change anyhthing.

i observed when it starts up it uses cpu and memory power but it seems to stops using cpu and memory power after ten seconds

what i have done to try resolving the issue

-following the general debugging steps
-deleting every add on and test which one is giving the fault but they simply all seem to have it
- deleting generated files
- deleting every single p3d folder
- uninstall and install p3d 4x times with no add ons which worked but with every add on i tried installing the same thing
happened again
- checked the prepar3d forum for other cases but they all solved it by reinstalling or by other things that didn't work for me
- checking for missing files in cmd with chkdsk etc..
- updating windows
- updating nvidia drivers
- reverting to nvidia driver i know worked

does anyone know anything else i could try ?

User avatar
Posts: 2770
Joined: Sat Nov 01, 2014 4:12 pm

Re: P3D V4.3 stuck at splash screen

Postby Poppet » Fri Jul 13, 2018 3:21 pm

Hello lowigiej

Welcome to the Prepar3D Forum

Can you click the link below and try the steps outlined in the post



If you are still having Issues please go through these steps one by one to help resolve your situation


Let us know how you get on

Posts: 1
Joined: Sat Jul 14, 2018 5:46 am

Re: P3D V4.3 stuck at splash screen

Postby mamento67 » Sat Jul 14, 2018 5:49 am

I have literally tried everything and no luck. I've used the "Deleted Generated Files", deleted scenery.cfg, repairing P3D V4.3 from the installer, updated windows, and even tried a new fresh install for P3D V4.3 with no add ons. I have just reinstalled the V4.2 Client and P3D is now working like a charm.

Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot] and 16 guests